Monsieur Excel
Pour tout savoir faire sur Excel !

28 janvier 2018

Simulation de dés (a)

Nous nous attaquons aujourd’hui, forts de notre nouvelle expérience en gestion du calcul itératif – cf. les trois derniers articles – dans la simulation de 10 lancements d’un dé. Nous avons construit à cet effet le modèle suivant :


Voici les formules de ce modèle :
B3 : =SI(B2=0;0;B3+1)
B4 : =SI(B2=0;"";ENT(6*ALEA()+1))
E1 (recopiée jusqu’en E6) : =SI($B$2=0;0;E1+SI($B$4=D1;1;0))
F1 (recopiée jusqu’en F6) : =E1/$B$3
E7 (recopiée en F7) : =SOMME(E1:E6)

Nous sommes pour le présent en calcul automatique, comme c’est le cas par défaut dans Excel.

Si tout se passe bien, nous pourrons ensuite nous mettre en calcul manuel, avec un maximum de 10 itérations, entrer 1 en B2, puis faire [F9] pour lancer la simulation des 10 dés.

Eh bien, si vous le faites, vous allez avoir la surprise de votre vie !
Voici donc un exemple de résultat obtenu après une telle simulation :


 Manifestement, nous devons être en train de jouer avec un truand qui a un dé pipé !

Dans le prochain article, nous découvrirons d’où vient le problème, puis comment le résoudre…

2 Commentaire(s):

  • Tres fort en effet!
    D’après moi, le calcul itératif se fait à l’intérieur de la cellule (?) puis de gauche a droite, et de bas en haut; effet, si on place une formule en amont de compteur (à gauche) on obtient n-1 itérations alors que le compteur en compte n.

    Il n'y a pas d’itération sur la formule ALEA(), donc il n'y a qu'une seule valeur calculée pour cette cellule. les cellules en colonne E verront donc n fois le même lancement.
    On peut réaliser un dé imaginaire avec x faces (par exemple 20), et prolonger la formule en colonne E et F. Si on insère une itération dans le lancement du dé (en B4), on voit qu'il y a bien n lancements (pour un calcul de n itérations).

    Une autre idée?

    By Blogger Yves Seybel, sur 5:14 PM  

  • Bonjour, je découvre tout juste votre blog ; je développe des jeux d'entreprises sous excel et suis souvent amené à utiliser des liaisons entre fichiers... et cela génère nombre de problèmes (les liaisons se perdent très facilement ) : en utilisez vous ? prévoyez vous d'écrire sur le sujet ? merci K. LAMA

    By Anonymous LAMA, sur 11:32 AM  

Enregistrer un commentaire

<< Accueil